Заявка #1492

Заявка на включение в репозиторий: VLC, gstreamer кодеки, библиотеки, ffmpeg

Добавил(а) Egor Zaharov больше 1 года назад. Обновлено больше 1 года назад.

Статус:ОтложенаНачата:11.10.2015
Приоритет:НормальныйДата выполнения:
Назначена:-Готовность:

0%

Категория:-Затраченное время:-
Версия:-
Теги:


Описание

Пакеты(в алфавитном порядке):
a52dec: https://github.com/nexfwall/a52dec/blob/master/a52dec.spec
faac: https://github.com/nexfwall/faac/blob/master/faac.spec
faad2: https://github.com/nexfwall/faad2/blob/master/faad2.spec
ffmpeg: https://github.com/nexfwall/ffmpeg/blob/master/ffmpeg.spec
gpac: https://github.com/nexfwall/gpac/blob/master/gpac.spec
gstreamer1-libav: https://github.com/nexfwall/gstreamer1-libav/blob/master/gstreamer1-libav.spec
gstreamer1-plugins-bad-freeworld: https://github.com/nexfwall/gstreamer1-plugins-bad-freeworld/blob/master/gstreamer1-plugins-bad-freeworld.spec
gstreamer1-plugins-ugly: https://github.com/nexfwall/gstreamer1-plugins-ugly/blob/master/gstreamer1-plugins-ugly.spec
gstreamer-ffmpeg: https://github.com/nexfwall/gstreamer-ffmpeg/blob/master/gstreamer-ffmpeg.spec
gstreamer-plugins-bad: https://github.com/nexfwall/gstreamer-plugins-bad/blob/master/gstreamer-plugins-bad.spec
gstreamer-plugins-bad-nonfree: https://github.com/nexfwall/gstreamer-plugins-bad-nonfree/blob/master/gstreamer-plugins-bad-nonfree.spec
gstreamer-plugins-ugly: https://github.com/nexfwall/gstreamer-plugins-ugly/blob/master/gstreamer-plugins-ugly.spec
lame: https://github.com/nexfwall/lame/blob/master/lame.spec
libdca: https://github.com/nexfwall/libdca/blob/master/libdca.spec
libdvbpsi: https://github.com/nexfwall/libdvbpsi/blob/master/libdvbpsi.spec
libmad: https://github.com/nexfwall/libmad/blob/master/libmad.spec
libmimic: https://github.com/nexfwall/libmimic/blob/master/libmimic.spec
libmms: https://github.com/nexfwall/libmms/blob/master/libmms.spec
libmpeg2: https://github.com/nexfwall/libmpeg2/blob/master/libmpeg2.spec
libquicktime: https://github.com/nexfwall/libquicktime/blob/master/libquicktime.spec
mjpegtools: https://github.com/nexfwall/mjpegtools/blob/master/mjpegtools.spec
mpg123: https://github.com/nexfwall/mpg123/blob/master/mpg123.spec
opencore-amr: https://github.com/nexfwall/opencore-amr/blob/master/opencore-amr.spec
rtmpdump: https://github.com/nexfwall/rtmpdump/blob/master/rtmpdump.spec
twolame: https://github.com/nexfwall/twolame/blob/master/twolame.spec
vlc: https://github.com/nexfwall/vlc/blob/master/vlc.spec
vo-amrwbenc: https://github.com/nexfwall/vo-amrwbenc/blob/master/vo-amrwbenc.spec
x264: https://github.com/nexfwall/x264/blob/master/x264.spec
x265: https://github.com/nexfwall/x265/blob/master/x265.spec
xvidcore: https://github.com/nexfwall/xvidcore/blob/master/xvidcore.spec

Все были взяты из RPMFusion. Изменения пока минимальные.

История

#1 Обновлено Vasiliy Glazov больше 1 года назад

Это большой шаг. Пока мы только говорили об этом, но не решались.
Ты потянешь постоянно обновлять эти пакеты для всех текущих версий Fedora?

К тому же не возникнет ли конфликтов с пакетами из rpmfusion?

#2 Обновлено Egor Zaharov больше 1 года назад

Vasiliy Glazov писал(а):

Это большой шаг. Пока мы только говорили об этом, но не решались.
Ты потянешь постоянно обновлять эти пакеты для всех текущих версий Fedora?

К тому же не возникнет ли конфликтов с пакетами из rpmfusion?

Я думаю могут возникнуть. Ибо если у них окажется версия либы новее, чем у нас, это будет непредсказуемо.
Но учитывая их тормознутость с релизами, если держать всё в актуальном состоянии, может проканать.

Пакеты сбилдил, ибо надоело ждать, пока их ленивые задницы поднимутся, и соберут кодеки под Fedora 23. Да и просто хотелось себя опробовать.

Под 23-ю вон новый gstreamer вышел, а они тупо делают симлинк на 22-ую. И так каждый тестовый релиз. Что делать то с ними?

#3 Обновлено Vasiliy Glazov больше 1 года назад

Уверен, что сможешь держать всё в актуальном состоянии?

#4 Обновлено Maxim Orlov больше 1 года назад

К тому же не возникнет ли конфликтов с пакетами из rpmfusion?

Я думаю могут возникнуть. Ибо если у них окажется версия либы новее, чем у нас, это будет непредсказуемо.

@Егор Захаров у тебя vlc-2.2.1, а прилетит из rpmfusion 2.2.2

[maxim@ip197-221 ~]$ su -
Пароль:
[root@ip197-221 ~]# dnf provides vlc
Last metadata expiration check performed 5:26:49 ago on Mon Oct 12 16:29:49 2015.
vlc-2.2.2-0.1.fc22.x86_64 : The cross-platform open-source multimedia framework, player and server
Источник: rpmfusion-free-updates

vlc-2.2.1-6.fc22.x86_64 : The cross-platform open-source multimedia framework, player and server
Источник: rpmfusion-free

#5 Обновлено Egor Zaharov больше 1 года назад

Maxim Orlov писал(а):

К тому же не возникнет ли конфликтов с пакетами из rpmfusion?

Я думаю могут возникнуть. Ибо если у них окажется версия либы новее, чем у нас, это будет непредсказуемо.

@Егор Захаров у тебя vlc-2.2.1, а прилетит из rpmfusion 2.2.2

[maxim@ip197-221 ~]$ su -
Пароль:
[root@ip197-221 ~]# dnf provides vlc
Last metadata expiration check performed 5:26:49 ago on Mon Oct 12 16:29:49 2015.
vlc-2.2.2-0.1.fc22.x86_64 : The cross-platform open-source multimedia framework, player and server
Источник: rpmfusion-free-updates

vlc-2.2.1-6.fc22.x86_64 : The cross-platform open-source multimedia framework, player and server
Источник: rpmfusion-free

Значит они уже обновили... Ну ладно.

#6 Обновлено Egor Zaharov больше 1 года назад

Vasiliy Glazov писал(а):

Уверен, что сможешь держать всё в актуальном состоянии?

Свяжись со мной по Email. Тут оказывается кое-что назревает, и если оно пройдёт успешно, то этот тикет станет бессмысленным.

#7 Обновлено Egor Zaharov больше 1 года назад

Тикет прошу закрыть. Появились другие опции.
Кому нужны кодеки gstreamer под F23, обратитесь ко мне(желательно через Telegram). Я кину сборку.

#8 Обновлено Vasiliy Glazov больше 1 года назад

  • Параметр Статус изменился с Новая на Отложена

#9 Обновлено Maxim Orlov больше 1 года назад

Может все таки вернемся к обсуждению, каждый взял бы по пару пакетов и всего делов то и определили бы кодеки сюда. А то rpmfusion я считаю уже труп как ни крути, Ascot-repo умер так и не родившись.

#10 Обновлено Vasiliy Glazov больше 1 года назад

Ох не перед Новым Годом это обсуждать...

Ни кому не хочется брать на себя лишнюю работу.

#11 Обновлено Maxim Orlov больше 1 года назад

Ни кому не хочется брать на себя лишнюю работу.

Зато все хотят чтобы все было и сразу. Ладно тогда я тихо и не спеша буду делать все нужное для себя.

#12 Обновлено Egor Zaharov больше 1 года назад

Maxim Orlov писал(а):

Может все таки вернемся к обсуждению, каждый взял бы по пару пакетов и всего делов то и определили бы кодеки сюда. А то rpmfusion я считаю уже труп как ни крути, Ascot-repo умер так и не родившись.

RPMFusion ещё не определился, труп он или не труп. Вроде бы что-то даже обновляется полтора мейнтейнерами, а вроде и запоздало.

Вот когда откроет кто-нибудь тикет у них, и попросит их окончательно трупом стать, тогда надо будет пересобирать всё здесь. А собирать параллельно, зачем?

#13 Обновлено Maxim Orlov больше 1 года назад

Да как ни крути труп он, уже считай три месяца прошло, а репа так и не готова, а

А собирать параллельно, зачем?

да затем, чтобы хоть кодеки были, лично я вчера убрал у себя репу rpmfusion и сделал нужные кодеки для себя, теперь я не завишу от полумертвого репозитория.

#14 Обновлено Maxim Orlov больше 1 года назад

PS. для того чтобы заиграла музыка в плеере который я использую lollypop, достаточно всего

gstreamer1-plugins-ugly

ну и чтобы его собрать, нужны

a52dec
libmad
libmpeg2
opencore-amr
twolame-libs

и всего то делов ...

Экспортировать в Atom PDF