Ошибка #547

не возможна авторизация compiz-gnome

Добавил(а) Grigoreo G больше 7 лет назад. Обновлено около 6 лет назад.

Статус:ЗакрытаНачата:20.04.2011
Приоритет:НизкийДата выполнения:
Назначена:Alexei PanovГотовность:

0%

Категория:Система
Версия:15
Bugzilla-Id: Upstream bug:http://bugzilla.redhat.com/show_bug.cgi?id=657020

Описание

при установленом пакете compiz-gnome и выбраном режиме Classic Gnome 2 не работают нормально пакеты которым нужна авторизация до root, в итоге пакеты кричать что не смогли авторизоватся под рутом , в частности system-config-firewall, установка удаление программ.

555.png (116,469 КБ) Алексей Чечель, 27.06.2011 21:34

История

#1 Обновлено Alexei Panov больше 7 лет назад

  • Параметр Статус изменился с Новая на Обратная связь
  • Параметр Приоритет изменился с Нормальный на Низкий

Пожалуйста, поясните, суть проблема - не понятна. Где это происходит? Какая версия Fedora? Версии используемых пакетов?

#2 Обновлено Grigoreo G больше 7 лет назад

Alexei Panov писал(а):

Пожалуйста, поясните, суть проблема - не понятна. Где это происходит? Какая версия Fedora? Версии используемых пакетов?

Fedora 15 Beta, system-config-firewall 1.2.29, gpk-application 3.0.0

#3 Обновлено Alexei Panov больше 7 лет назад

  • Параметр Категория изменился на Система
  • Параметр Статус изменился с Обратная связь на Новая
  • Параметр Назначена изменился на Alexei Panov
  • Параметр Версия изменился на 15

#4 Обновлено Alexei Panov больше 7 лет назад

  • Параметр Статус изменился с Новая на Ожидание исправления в upstream
  • Параметр Upstream bug изменился на http://bugzilla.redhat.com/show_bug.cgi?id=657020

Похоже одна и та же ошибка https://bugzilla.redhat.com/show_bug.cgi?id=657020 хоть и относится к 14-ой федоре.
Ждем исправлений, рекмоендую подписаться.

#5 Обновлено Алексей Чечель больше 7 лет назад

  • Файл 555.png добавлен

Проблему подтверждаю, при установке любого пакета вместо запроса пароля - сообщение "Сбой авторизации"

#6 Обновлено Alexei Panov больше 7 лет назад

  • Параметр Статус изменился с Ожидание исправления в upstream на Обратная связь

Если исправить файл /usr/share/polkit-1/actions/org.fedoraproject.config.firewall.policy следующим образом:

<defaults>
<allow_any>auth_admin</allow_any>
<allow_inactive>auth_admin</allow_inactive>
<allow_active>auth_admin_keep</allow_active>
</defaults>

Включить пользователя в группу wheel и перезайти в сеанс, ошибка исправляется?

#7 Обновлено Алексей Чечель больше 7 лет назад

Alexei Panov писал(а):

Если исправить файл /usr/share/polkit-1/actions/org.fedoraproject.config.firewall.policy следующим образом:

<defaults>
<allow_any>auth_admin</allow_any>
<allow_inactive>auth_admin</allow_inactive>
<allow_active>auth_admin_keep</allow_active>
</defaults>

Включить пользователя в группу wheel и перезайти в сеанс, ошибка исправляется?

После этого действия: в момент, когда должно появится окно авторизации падает компиз, а установка (или другое действие проходят успешно без запроса пароля)

#8 Обновлено Алексей Чечель больше 7 лет назад

С компизом лажанулся, проблема была в другом, просто совпадение.

#9 Обновлено Alexei Panov больше 7 лет назад

Так я не понял, совет помогает или нет?

#10 Обновлено Алексей Чечель больше 7 лет назад

Нет. Просто в тот момент еще слетел компиз и я не увидел окошка с надписью "Failed to obtain authentication."

#11 Обновлено Alexei Panov больше 7 лет назад

  • Параметр Статус изменился с Обратная связь на Ожидание исправления в upstream

Спасибо, понял.
Продолжаем наблюдать, рекомендую подписаться также на ошибку https://bugzilla.redhat.com/show_bug.cgi?id=624537
Одна из ошибок, скорее всего останется, другую закроют, как дубликат.

#12 Обновлено Alexei Panov около 7 лет назад

  • Параметр Статус изменился с Ожидание исправления в upstream на Обратная связь

В Fedora 16 ошибка воспроизводится?

#13 Обновлено Ignat Sazhaev около 7 лет назад

Да, все тоже самое. Почему то по умолчанию в compiz-gnome сессию не включен запуск агента аутентификации.
Если запустить вручную то авторизация проходит:
exec /usr/libexec/polkit-gnome-authentication-agent-1

#14 Обновлено Alexei Panov около 7 лет назад

  • Параметр Статус изменился с Обратная связь на Ожидание исправления в upstream

#15 Обновлено Peter Lemenkov около 6 лет назад

  • Параметр Статус изменился с Ожидание исправления в upstream на Отказано

15я Fedora давно не поддерживается, да и compiz уже удалили. Я закрываю

#16 Обновлено Андрей Савинов около 6 лет назад

  • Параметр Статус изменился с Отказано на Закрыта

Экспортировать в Atom PDF